Fully managed cloud. 30-day FREE full featured trial. Start Now
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to connect to on-prem instance

ecoh_dr
SQL-Fighter

Hello. I'm attending the "Exasol Administration on premises" course and I'm experiencing some issues connecting to the database.

I followed all the instructions provided by the Activity Guide and the videos on how to setup a 2+1 cluster by using Virtualbox VMs. Now the 3 nodes (plus the License Server) are in Running Active state:

Nodes.png

The Storage service is activated:

storage.png

The database is in Running status:

db.png

When I try to connect to the database using EXAplus I get the following error message:

 

C:\Program Files\EXASOL\EXASolution-7.1\EXAplus>exaplusx64.exe -c 192.168.56.11..13:8563 -jdbcparam validateservercertificate=0
EXAplus 7.1.7 (c) EXASOL AG

User: sys
Password: ******

Error: [08001] Remote host closed connection during handshake

 

 

Please note I downloaded the ISO image following this direct link, that lets you to download the "EXASuite-6.1.2-RELEASE.iso" file.

As you can notice above, my EXAplus (and JDBC) version is 7.1.7; I don't know if this can have an impact, but maybe not for backward compatibility.

Thank you in advance for your replies.

1 ACCEPTED SOLUTION

Accepted Solutions

exa-Aleksandr
Team Exasol
Team Exasol

Hi @ecoh_dr ,

Could you try to replace

validateservercertificate=0 with legacyencryption=1 in jdbcparam parameter of EXAPlus?

View solution in original post

7 REPLIES 7

exa-Uwe
Moderator
Moderator

Hi,

we haven't tested this with the EXAPlus CLI at all, just with DbVisualizer. 6.1.2 is quite old meanwhile, although the topics we discuss during that course should still be valid with that version. Could you try to connect with DbVisualizer? It has a free version that is sufficient for this course.

ecoh_dr
SQL-Fighter

Hi Uwe and thank you for your reply.

I use DBeaver as my SQL editor. After having set up the connection with all the proper parameters, when I try to connect it remains stuck and it does nothing, even if the connectimeout parameter is set to 1000, e.g. one second.

ecoh_dr_0-1656068052260.png

 

By the way, I'd like to have a fully functioning environment in view of the final certification exam.

exa-Aleksandr
Team Exasol
Team Exasol

Hi @ecoh_dr ,

Could you try to replace

validateservercertificate=0 with legacyencryption=1 in jdbcparam parameter of EXAPlus?

exa-Uwe
Moderator
Moderator

Hi,

I have changed the file behind the download link to the more recent version 7.1.10 now. Tested it and I can confirm the installation works and the database can be accessed both with DbVisualizer and EXAplus CLI (version 7.1.10 too) by adding the fingerprint to the hostname like in this example:

C:\Program Files\Exasol\EXASolution-7.1\EXAplus>java -jar exaplus.jar -c 192.168.56.11..12/4AF4BF38F16C41C479AF020ED8699CB26B1627ADA68217D4A4BA8D6B84F649E5:8563 -u sys -P exasol

Means you'll have to repeat the installation - but the description in the course is still completely valid. Thank you for bringing this to our attention &

Best regards

Uwe

ecoh_dr
SQL-Fighter

Hi exa-Aleksandr, thank you for your reply. As soon as possible I'll give it a try.

ecoh_dr
SQL-Fighter

Hi Uwe. As I wrote in my previous post, I'll test the tip provided by Alexandr and I'll let you know if it worked as expected; otherwise, I'll proceed to a brand new installation.

As Romans said, "repetita iuvant" (repeating does good).

ecoh_dr
SQL-Fighter

Hi Aleksandr. Switching validateservercertificate=0 with legacyencryption=1 did the magic.

Thank you (and Uwe, too) once again.