Unable to access admin WEB UX using single node Docker image

ncampbell
Padawan

Downloaded docker build of 7.1.2
Started instance

Can connect and do things via Exasol JDBC driver (create user, schema, table etc)

Cannot connect via the admin web UX, which I assume is required to change the configuration to enable OpenID support.
If there is a non-UX way to define those properties, would someone share the details/docs.

As is cannot use the UX, both show following which appears wrong.

http://<machine>
https://<machine>:443 

ncampbell_0-1636130343458.png

 



docker run --name exasoldb  -p 80:80 -p 8563:8563 -p 443:443 --detach --privileged --stop-timeout 120 -v ~exasol/exavol:/exa exasol/docker-db:latest

1 ACCEPTED SOLUTION

Accepted Solutions

exa-Nico
Community Manager
Community Manager

Hi @ncampbell - In Docker installations, there is no Admin UI. Instead, everything is managed by a configuration file. Check out this article on how to add the parameters to the file:

https://community.exasol.com/t5/environment-management/setting-a-database-parameter-in-a-docker-base...

You'll need to add the line starting with Params and then specify all of the OpenID parameters there.

Hope it helps! 

 

Sports Enthusiast. Database Guy. Member of Team Exasol.
Having trouble? Just let me know!

Please Give Kudos if you find this post useful and also mark this as Accepted Solution if this is the required solution

View solution in original post

2 REPLIES 2

exa-Chris
Community Manager
Community Manager

Thanks, as promised I will nudge internally, as its already friday evening, I am not sure if I get an answer before monday morning our time. Rgds

Christian

Connecting Customers, Partners, Prospects and Exasolians is my passion. Apart from that I cycle, listen to music, and try to understand what all those technical discussions really mean...

exa-Nico
Community Manager
Community Manager

Hi @ncampbell - In Docker installations, there is no Admin UI. Instead, everything is managed by a configuration file. Check out this article on how to add the parameters to the file:

https://community.exasol.com/t5/environment-management/setting-a-database-parameter-in-a-docker-base...

You'll need to add the line starting with Params and then specify all of the OpenID parameters there.

Hope it helps! 

 

Sports Enthusiast. Database Guy. Member of Team Exasol.
Having trouble? Just let me know!

Please Give Kudos if you find this post useful and also mark this as Accepted Solution if this is the required solution

View solution in original post