Trouble with SQL Server connections with integrated sign-on

Xpert

I’m having issues establishing a connection with SQL Server from Exasol for AD integrated logins. Does anyone have experience with this? Are there any tricks? I’ve done this several times, but for some reason I’m having trouble now.

CREATE OR REPLACE CONNECTION PHCMD221_CIT_RM to'jdbc:jtds:sqlserver://phcmd221.domain.org:1433;databaseName=CIT_RM;debug=1;logdir=/dump/' user 'userID' identified by '<SECRET>';

WITH CTE AS (
    SELECT * FROM (IMPORT FROM JDBC AT PHCMD221_CIT_RM STATEMENT 'SELECT TOP 100 * FROM dbo.dm_ci_metric_score')
)
SELECT * FROM CTE
;

 

I verified the account has access via SSMS. But I get the following error when trying to query the database:

[ETL-5] JDBC-Client-Error: Connecting to 'jdbc:jtds:sqlserver://phcmd221.domain.org:1433;databaseName=CIT_RM;debug=1;logdir=/dump/' as user='userID' failed: Login failed for user 'userID'. (Session: xxxx)

Note that UserID and <SECRET> are not the actual values.

1 ACCEPTED SOLUTION

Community Manager
Community Manager

Hey Mark! 

I've only done this once and it was a while ago, but I think the instructions are still valid. You need to add the following to your connection string:

domain=AD;useNTLMv2=true;

So whatever your domain is called (mine was called AD), then you would put that in the domain parameter. Then of course the user and password are the windows user and password. 

You can see my example in this article.

Let me know if that worked, or at least if you get a different error message!

Sports Enthusiast. Database Guy. Member of Team Exasol.
Having trouble? Just let me know!

Please Give Kudos if you find this post useful and also mark this as Accepted Solution if this is the required solution

View solution in original post

2 REPLIES 2

Community Manager
Community Manager

Hey Mark! 

I've only done this once and it was a while ago, but I think the instructions are still valid. You need to add the following to your connection string:

domain=AD;useNTLMv2=true;

So whatever your domain is called (mine was called AD), then you would put that in the domain parameter. Then of course the user and password are the windows user and password. 

You can see my example in this article.

Let me know if that worked, or at least if you get a different error message!

Sports Enthusiast. Database Guy. Member of Team Exasol.
Having trouble? Just let me know!

Please Give Kudos if you find this post useful and also mark this as Accepted Solution if this is the required solution

View solution in original post

Xpert

Sweet, worked like a charm! Thanks, Nico!