python-3.6-data-science-EXASOL-6.2.0 and UDFs

Franz_1
Padawan

Hi All,

To use in my own UDFs I have added additional python3 packages to BucketFS and have been able to proceed to this stage:

kaanmutlu_0-1629905717956.png

Then I ran this command to make my changes take effect

ALTER SYSTEM SET SCRIPT_LANGUAGES='PYTHON3=localzmq+protobuf:///bucketfs1/datascience/python-3.6-data-science-EXASOL-6.2.0_release?lang=python#buckets/bucketfs1/datascience/python-3.6-data-science-EXASOL-6.2.0_release/exaudf/exaudfclient_py3';

My question is that am I on the right track?
Does the bucket look right?
Even if so, how can I be sure that I can use the provided packages within "python-3.6-data-science-EXASOL-6.2.0" on Exasol?

It would be great if you could share if you have a complete guide or example for using additional python packages in UDFs Because even though I tried to continue by following the steps in this article, I found it a bit complicated 😅

Thanks, in advance

 

2 REPLIES 2

exa-Chris
Community Manager
Community Manager

Hi, if you want to test, this might be a solution: https://github.com/exasol/database-migration

Connecting Customers, Partners, Prospects and Exasolians is my passion. Apart from that I cycle, listen to music, and try to understand what all those technical discussions really mean...

mwellbro
Xpert

Hi @Franz_1 ,

are you running the community as an OVA ( i.e. virtual ) ? Might have something to do with the network config, as the error states the target network is unreachable - maybe this is worth checking out: https://community.exasol.com/t5/discussion-forum/mysql-communication-link-failure-the-driver-has-not... (it´s MySql and a different error message but the underlying problem might be the same ).

Or do you have a "full fledged" on premise install ? Or running on cloud ?

Cheers,
Malte