Fully managed cloud. 30-day FREE full featured trial. Start Now
cancel
Showing results for 
Search instead for 
Did you mean: 

Powershell connection error - SSL authentication failed

danila
SQL-Fighter

We updated all drivers to the version 7.1 and installed TLS certificates.

So, JDBC, ODBC connections are successful. C# application also can connect via ADO.NET driver.

But Powershell script, which also uses ADO.NET driver, is failing to connect.

Error: SSL authentication failed. AuthenticationException: A call to SSPI failed, see inner exception.
Error: Inner exception: The client and server cannot communicate, because they do not possess a common algorithm
Debug: Exasol.EXADataProvider.EXAClientException (0x80004005): TLS connection to host (exadb1) failed: A call to SSPI failed, see inner exception.
   at Exasol.EXADataProvider.backend.BackendFactory.ConnectToServer(String hostIp, Int32 serverPort, String serverName, String userFingerprint)
   at Exasol.EXADataProvider.backend.BackendFactory.PerformLogin(EXAConnectionStringBuilder connectString)

 

I've read that this error may occur when TLS 1.2 is not enabled. But when I check which security protocols are enabled ( [System.Net.ServicePointManager]::SecurityProtocol ), I see " Ssl3, Tls, Tls12 ".

What is weird is that Powershell connection works on my local computer (Windows 10), but doesn't work on the server (Windows Server 2016).

Does anyone have any idea what am I missing?

4 REPLIES 4

exa-Aleksandr
Team Exasol
Team Exasol

Hi @danila ,

Maybe it's a matter of not only protocol but also ciphers and you can experiment from Exasol side: https://www.exasol.com/support/browse/EXASOL-3060 or from Windows Server side?

danila
SQL-Fighter

@exa-Aleksandr , looks like you are right. I compared available ciphers on my computer and on the server: I have more

We'll try to upgrade Windows Server and see if it will unlock missing ciphers.

danila
SQL-Fighter

exa-Aleksandr
Team Exasol
Team Exasol

@danila thanks a lot for posting the reference to the working solution!