MySQL - communication link failure, the driver has not received any packets from the server

Uthsavi
Padawan

Hi everyone,

I am getting this error and I have tried all the possible solutions available on the internet.

Please help me with this.

ERROR MESSAGE:

[Code: 0, SQL State: ETL-5] JDBC-Client-Error: Connecting to 'jdbc:mysql://127.0.0.1:3306/exasol/' as user='root' failed: Communications link failure

The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server. (Session: 1702465781829795840)

Screenshot (253).png

Thank you in advance.

6 REPLIES 6

exa-Chris
Community Manager
Community Manager

Hi @Uthsavi thank you for your patience. @exa-PeterB will reach out to you directly and discuss your whole case, think that is a lot easier. We will report back. Thanks Christian

Connecting Customers, Partners, Prospects and Exasolians is my passion. Apart from that I cycle, listen to music, and try to understand what all those technical discussions really mean...

exa-Nico
Community Manager
Community Manager

Hi @Uthsavi -

The IP Address (127.0.0.1) refers to localhost, and in the connection in the database, that would basically mean you have a mysql server running on the same VM or machine that your Exasol environment is running, which is probably not the case. Where is the MySQL database running? Is it a setup where your local machine has a MySQL Database running and Exasol is running in a Virtual Machine? If it's a VM, how is the network setup? 

Sports Enthusiast. Database Guy. Member of Team Exasol.
Having trouble? Just let me know!

Please Give Kudos if you find this post useful and also mark this as Accepted Solution if this is the required solution

Uthsavi
Padawan

Hi,

MySQL is running on my local windows system and Exasol is running on oracle virtual machine(Ubuntu). In my VM network settings I have, Adapter1 - NAT and Adapter2 - Host-only.

exa-Nico
Community Manager
Community Manager

got it, thanks! Try to add port 3306 for both guest/host in your VM network settings (Network -> Adapter 1 -> Advanced -> Port Forwarding. Your port forwarding rules would look like this:

exaNico_0-1623653690927.png

Hopefully this will let you connect back to your local machine from the database over port 3306

Sports Enthusiast. Database Guy. Member of Team Exasol.
Having trouble? Just let me know!

Please Give Kudos if you find this post useful and also mark this as Accepted Solution if this is the required solution

Uthsavi
Padawan

Hi,

I have added these before in the port forwarding but still i am getting the same error.

Please help me with this.

Thank you

mwellbro
Xpert

Hi @Uthsavi ,

tried this with locally installed MYSQL and ExaOne within a Oracle-Virtual-Box:

mwellbro_0-1623684071447.png

In the connection from Exa to MYSQL I used the local privat address of my host - seems to work.
Network-config for ExaOne:

mwellbro_1-1623684192900.png


Hope this helps ? Or is your "two NIC setup" necessary from your end ?

Cheers,
Malte