JDBC ODBC Connection Failed

SuhasTalanki
Padawan

Hi All,

I tried installing the Exasol community edition and DBvisualizer.

I am getting the below error when try connecting to Exasol server. 

Type: com.exasol.jdbc.ConnectFailed
   SQL State: 08001

Can any one help me with this issue. I have even downloaded the latest ODBC drivers. But still I am facing the issue. 

Regards,

Suhas

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

exa-Uwe
Moderator
Moderator

Hi @SuhasTalanki ,

The "connect timed out" looks like a network issue. When you look at your VM settings, do they look like this?

exaUwe_0-1624258523737.png

An your host-only adapter should look like this:

exaUwe_1-1624258683758.png

 

View solution in original post

7 REPLIES 7

exa-Uwe
Moderator
Moderator

Hi Suhas,

that error doesn't have to be related to the driver. It may just be raised because the database server hasn't been specified correctly in DbVisualizer. Did you check your VM for the DB connection string? I mean this screen:

exaUwe_0-1623834521124.png

In my case, the IP is 192.168.56.114 - yours may be different. That's what you put as Database Server in DbVisualizer:

exaUwe_1-1623834639175.png

Hope that helps.

Best regards

Uwe

SuhasTalanki
Padawan

Hi @exa-Uwe ,

Thank you for your steps. I have followed these steps but still I am getting the same error. 

Regards,

Suhas Talanki

 

 

 

exa-Uwe
Moderator
Moderator

Okay, could you please take screenshots from the error as you get it as well as from the VM screen and the DbVisualizer connection like I did and add them here?

SuhasTalanki
Padawan

Hi @exa-Uwe ,

As requested plz find the below screenshots. 

SuhasTalanki_0-1624256038088.pngSuhasTalanki_1-1624256062161.png

 

 

exa-Uwe
Moderator
Moderator

Hi @SuhasTalanki ,

The "connect timed out" looks like a network issue. When you look at your VM settings, do they look like this?

exaUwe_0-1624258523737.png

An your host-only adapter should look like this:

exaUwe_1-1624258683758.png

 

View solution in original post

SuhasTalanki
Padawan

Hi @exa-Uwe 

Thank you for your quick help. I am able to connect to database. Your help is much appriciated. 

 

Harry0520
Padawan

Hi @exa-Uwe!

I have the same problem just now, and i have adjusted the settings of the VM ( they look like this), but still I am getting the same error.
Could you help me please?

Thanks in advance