Fully managed cloud. 30-day FREE full featured trial. Start Now
cancel
Showing results for 
Search instead for 
Did you mean: 

IMPORT FROM LOCAL CSV FILE can't find the file

BONFI
Padawan

Hello everybody, I'm new in this discussion and also an Exasol begginer.

I'm trying to import in Exasol a CSV file with the following statement:

IMPORT INTO MY_SCHEMA.MY_TABLE
FROM LOCAL CSV FILE 'C:/PROV.CSV'
COLUMN SEPARATOR = ';' SKIP = 1;

I placed the CSV file in C: , but I'm getting the following message:

[42636] java.sql.SQLException: ETL-5105: Following error occured while reading data from external connection [https://[...manually removed...] failed with error code=404 after 0 bytes.] (Session: 1727628899481616384) while executing 'IMPORT INTO MY_SCHEMA.MY_TABLE FROM CSV AT 'https://[...manually removed...]' FILE '2d23db10-d256-4b1a-b99d-70663c20a830' COLUMN SEPARATOR = ';' SKIP = 1;'; 04509 java.sql.SQLException: java.io.FileNotFoundException: File 'C:/PROV.CSV' not found.

Any help is appreciated.

Thanks, Maurizio.

1 ACCEPTED SOLUTION

Accepted Solutions

BONFI
Padawan

Hi Uwe thanks for your answer.

Based on what you said I remembered that I'm running Exaplus in a Citrix environment, after few checks I realized that the Import was not able to see the C: drive properly.

I moved the file to import into a Citrix folder and everything worked fine.

Thanks again,

Maurizio.

View solution in original post

2 REPLIES 2

exa-Uwe
Moderator
Moderator

Hi Maurizio,

as silly as it sounds, but are you sure that file is there?

Couple of observations:

It's a bit unusual to have a file directly on the C drive - on my corporate machine, I'm not allowed to place it there without admin rights, for example. I suggest you create a folder there and put the file there.

/ is not the same as \ - it may make a difference depending on your OS. Just to make sure, I recommend you use the correct \ like in this example

 

 

 

IMPORT INTO yourtable FROM LOCAL CSV FILE 'c:\yourfolder\yourfile.csv';

 

 

 

Hope that helps.

Best regards

Uwe

BONFI
Padawan

Hi Uwe thanks for your answer.

Based on what you said I remembered that I'm running Exaplus in a Citrix environment, after few checks I realized that the Import was not able to see the C: drive properly.

I moved the file to import into a Citrix folder and everything worked fine.

Thanks again,

Maurizio.