How to increase the limit of active sessions

Contributor

Hello. I'm working with a two nodes Exasol 6.2 installation, used as data source for Tableau dashboards. We're trying to optimize the connection between Exasol and Tableau looking for potential bottlenecks.

 

After having read the Session Management page, I had a look at the Exasol logs:

ecoh_dr_0-1606384154708.png

Another Community post adresses the same topic, but it doesn't provide a clear solution.

I would like to modify the maximum number of connections. The EXA_METADATA table contains these values:

ecoh_dr_1-1606384395272.png

Which one should I modify? And above all, how can I modify it? Being database parameters, I doubt a simple UPDATE would be enough.

By the way, where can I find a thorough explanation of the EXA_METADATA table values? The documentation isn't very extensive.

Thank you in advance.

 

Best regards,

Daniele

 

4 REPLIES 4

Contributor

Hello everyone. I'm back discussing this issue because I feel as it has become a personal challenge... En garde!

Jokes aside, I'm really interested in it and I would like to have a better understanding on how Exasol works.

The Session Management page states:

A session is defined as active if it matches at least one of the following conditions:

  • Performing query execution
  • Has open transactions
  • Has open prepared statement
  • Has open resultset
  • Has open sub-connection

Each active session occupies one active slot.

...

Currently, there is no way to find out the Connected states through system tables. Connected, inactive and Disconnected sessions should have a TEMP_DB_RAM_USAGE of 0.0 in the current session list.


If I correctly understand it, in fair approximation I could estimate the number of Connected, active sessions in a given moment having a look at the EXA_DBA_AUDIT_SESSIONS table and filtering by TEMP_DB_RAM_USAGE > 0. Right?


Kind regards,

Daniele

Community Manager
Community Manager

Hi @ecoh_dr - just to add on to what @mwellbro said....

Changing parameters should only be done on the recommendation of Exasol support. 

It is usually more worthwhile to investigate why you are getting close than to increase the limit. 

There is also a known bug regarding the display of that error message in Exaoperation (https://www.exasol.com/support/browse/EXASOL-2724), but if you are actually hitting the limit very regularly, we can take a look at it.

Hitting the warning trigger does not have any impact for users or queries - it's just an FYI in Exaoperation to make you aware of it. 

Sports Enthusiast. Database Guy. Member of Team Exasol.
Having trouble? Just let me know!

Please Give Kudos if you find this post useful and also mark this as Accepted Solution if this is the required solution

Contributor

Hi @exa-Nico and @mwellbro . First and foremost, thank you for your answers.

I'll stick to your tips. It's clear I need to further investigate on if it's a bug or a real problem. Maybe activating the auditing tool would suffice to get some more insights.

Xpert

Hi @ecoh_dr ,

setting different parameters would require a restart of your DB instance - also, normally you shouldn´t "play" with those setting, at least not without talking it through with exa support ( or on an expandable test environment 😉 ).

Regarding more than 100 ACTIVE sessions: bear in mind that each session would ( under standard resource management conditions ) receive only 1/100 of your systems performance/resources - I don´t think you´d want that.

Why do you have that many ACTIVE sessions in parallel ? Is that a tableu thing ? As Exa mentions on occasion, they are query throughput optimized, so any given query should finish rather quickly and the system should not be "bogged down" with lots and lots of concurrent ACTIVE sessions.

Maybe some details on how this "session bonanza" gets created ?

Cheers,
Malte