Export views into csv files - get rid of decimal places

Contributor

Hi friends,

How can I get rid of decimal places in my exported csv files?
Currently the entries of my exported csv file looks like this:

Moritz_0-1593004440468.png

The underlying TYPE of the attribute is a DECIMAL. 
I would be pleased if someone could help me out.

Best
Moritz

 

2 REPLIES 2

Contributor

Have you tried using the format model with the export statement? Below is an example on how you can specify the column formats in the export command.

 

EXPORT (SELECT 10) INTO LOCAL CSV FILE 'test_export.csv'
(1 FORMAT='FM9999,999');

Xpert

Hi Moritz,
in what application was this opend ?

export (
select CAST(100000.3 as decimal(18,2)) as val from dual)
into local csv file 'C:\temp\out.csv';

=> yields a "classic" 100000.3 in notepad...

Maybe your NLS-Settings are off ?