ExaConnectionFailedError

hye
Contributor

Hello All,

 

I am currently struggling to solve a connection error(could not connect to Exasol: timed out) to Exasol with the following string in Jupyter Notebook or Spyder (Anaconda 3). My colleague has executed the same string in his laptop and it works well without having any error. 

  • String: connection = pyexasol.connect(dsn='host:port', user='USERNAME', password='PASSWORD', schema = 'SCHEMA')

Captura1.PNG

 

Could anybody help me out to solve the error? 

Thank you in advance for your help. 

 

1 ACCEPTED SOLUTION

Accepted Solutions

hye
Contributor

Thank you all @exa-Chris @littlekoi for your comment.

 

I have solved the errror confirguring environment variables in local setting. It was due to the configuration of http proxy and delating the proxy the problem is solved 🙂 

 

Many thanks again and wish you Happy Christmas! 

View solution in original post

3 REPLIES 3

exa-Chris
Community Manager
Community Manager

Good Morning, thanks for the question. Let me see whom I can ping on this. Christian

Connecting Customers, Partners, Prospects and Exasolians is my passion. Apart from that I cycle, listen to music, and try to understand what all those technical discussions really mean...

littlekoi
Xpert

Usually it means something is blocking your connection (e.g. firewall, VPN rules).

Does connection using JDBC / ODBC drivers work for you?

Also, in some rare cases, if Exasol connection server is overloaded, default "connection_timeout" value of 10 seconds might not be enough. It can be increased using connection option "connection_timeout=60".

More about connection options: https://github.com/exasol/pyexasol/blob/master/docs/REFERENCE.md#connect

hye
Contributor

Thank you all @exa-Chris @littlekoi for your comment.

 

I have solved the errror confirguring environment variables in local setting. It was due to the configuration of http proxy and delating the proxy the problem is solved 🙂 

 

Many thanks again and wish you Happy Christmas! 

View solution in original post