Character is not allowed within quoted identifiers

cpohlmann
Contributor

If I try to access a table from Tableau (ODBC) I get the following error:
[EXASOL][EXASolution driver]'.' character is not allowed within quoted identifiers [line 16, column 32] (Session: 1707907005981458432)
Fehlercode: 1E953F46

I do not see any quoted column with a "."  in it. How can this issue be solved? 

 

Best

Christian

1 ACCEPTED SOLUTION

cpohlmann
Contributor

I found a workaround by setting the Tableau variable CAP_ODBC_BIND_FORCE_MEDIUM_STRING_BUFFERS to "yes". https://help.tableau.com/current/pro/desktop/de-de/odbc_capabilities.htm 

 

View solution in original post

5 REPLIES 5

cpohlmann
Contributor

I found an old ticket with the same problem but in combination with Qlik and not Tableau: https://www.exasol.com/support/browse/SOL-371

How can this be solved with Tableau?

mwellbro
Xpert

Hi @cpohlmann ,

check:
select * from exa_dba_audit_sql where session_id=1707907005981458432 and success=false;

This should tell you what Tableau is up to and give you an indication what you´re dealing with ( see column SQL_TEXT ).

Prerequisite: Auditing is enabled on your database ( as it should be 😉  ).

Cheers,
Malte

cpohlmann
Contributor

Yes, now I see the SQL statements Tableau generates for some calculations. And some column identifier have a "." in it. Is there a way to allow it (maybe via ODBC setting)? 

 

mwellbro
Xpert
Hmmm, none that I know of.
Maybe check back with exa support?
Or see if there is a way to get Tableau to not use a dot in their identifieres ?
Just ideas at this point.

Cheers,
Malte

cpohlmann
Contributor

I found a workaround by setting the Tableau variable CAP_ODBC_BIND_FORCE_MEDIUM_STRING_BUFFERS to "yes". https://help.tableau.com/current/pro/desktop/de-de/odbc_capabilities.htm 

 

View solution in original post