Cannot connect to Community Edition 7.1 VM

cpohlmann
Contributor

Hi,

I downloaded the Community Edition 7.1. and successfully run the Exasol in VirtualBox. I can also access the EXAoperation in my local browser. But if I try to connect with DBeaver I get the following error:

 

java.io.IOException: TLS connection to host (192.168.56.101) failed: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target. If you trust the server, connect to it using the fingerprint: 8FB3BE3AABF823AE16F4F518A153B29B8C097BBE0853A7A40FB6C105D9A441C0.

 

Any idea what I can do to fix it?

 

Thank you

Christian

2 ACCEPTED SOLUTIONS

mwellbro
Xpert

Hi @cpohlmann ,

maybe setting 

-jdbcparam validateservercertificate=0

in the connection props might help you - be advised that with this you´ll do exactly what the param suggests, so it´s not a secure solution.

I think this was something that´s new with 7.1 - if you want to go with the fingerprint method adjust the jdbc connect string as follows ( haven´t tested it yet ) :
jdbc:exa:exadb1.example.com/jdbc:exa:exadb1.example.com/72975b4d331deeb44fa41fb858a5417e163151bbfb45376574706800a8dcce30:8563

There should be something about this in the documentation, not sure were - maybe someone from exa can expand on this thread.

Cheers,
Malte

View solution in original post

mwellbro
Xpert

update: thanks to @exa-Tobias we now have the link to the doc´s at the bottom

For ODBC you´d go for SSLCertificate=SSL_VERIFY_NONE
or 
EXAHOST=exadb1.example.com/<fingerprint>:8563 for the fingerprint based approach

https://www.exasol.com/support/browse/EXASOL-2936

 

View solution in original post

6 REPLIES 6

cpohlmann
Contributor

The same problems appears if connecting to Tableau (via ODBC) and here I do not have the chance to set parameters, right?

 

mwellbro
Xpert

update: thanks to @exa-Tobias we now have the link to the doc´s at the bottom

For ODBC you´d go for SSLCertificate=SSL_VERIFY_NONE
or 
EXAHOST=exadb1.example.com/<fingerprint>:8563 for the fingerprint based approach

https://www.exasol.com/support/browse/EXASOL-2936

 

View solution in original post

cpohlmann
Contributor

Yes, if I use "Other ODBC source" and set the Parameter in my local ODBC connection it works!

exa-Chris
Community Manager
Community Manager

@mwellbro you are amazing!!!

Connecting Customers, Partners, Prospects and Exasolians is my passion. Apart from that I cycle, listen to music, and try to understand what all those technical discussions really mean...

mwellbro
Xpert

Hi @cpohlmann ,

maybe setting 

-jdbcparam validateservercertificate=0

in the connection props might help you - be advised that with this you´ll do exactly what the param suggests, so it´s not a secure solution.

I think this was something that´s new with 7.1 - if you want to go with the fingerprint method adjust the jdbc connect string as follows ( haven´t tested it yet ) :
jdbc:exa:exadb1.example.com/jdbc:exa:exadb1.example.com/72975b4d331deeb44fa41fb858a5417e163151bbfb45376574706800a8dcce30:8563

There should be something about this in the documentation, not sure were - maybe someone from exa can expand on this thread.

Cheers,
Malte

View solution in original post

cpohlmann
Contributor

Great @mwellbro  works with the jdbcparam!

Best

Christian