Alteryx + 7.1?

drumcircle
Rising Star

Has anyone been successful connecting Alteryx 2020.1 (or later) to Exasol 7.1?  My associate is getting an "unable to create socket" exception even though ODBC Driver Manager connects successfully.

1 ACCEPTED SOLUTION

Accepted Solutions

drumcircle
Rising Star

There is an undocumented flag which resolves windows ODBC connection issues from tools like Excel and Alteryx in version 7.1

In the ODBC data source administration, supply the additional, advanced parameter LegacyEncryption=Y.
 
1. Go to ODBC Data Source Administrator (64-bit).
2. Select the DSN and click Configure.
3. Go to Advanced tab.
4. In the field of Additional connection string parameters, add the below line
 
LegacyEncryption=Y
 
5. Now, go to Connection tab and click Test Connection. If the connection is successful, then click Ok else check the configuration once again.
6. Now, try to establish the connection using the configured DSN in Microsoft Excel. If still the error is persisting, then please send the ODBC log file generated by the Microsoft Excel for the newly configured DSN.

Thank you support for finding a solution.  I suspect there will be a new approach in the future.

View solution in original post

6 REPLIES 6

exa-Chris
Community Manager
Community Manager

HI Anthony, let me nudge someone internally. Coming back ASAP. Christian

Connecting Customers, Partners, Prospects and Exasolians is my passion. Apart from that I cycle, listen to music, and try to understand what all those technical discussions really mean...

exa-ThomasB
Team Exasol
Team Exasol

@drumcircle   I could reproduce the error, will create ODBC logs and let it analyze by support to see if it is onour end

exaThomasB_0-1633442193352.png

 

drumcircle
Rising Star

Same issue for Excel (ie. underlying windows odbc 32/64 issue) using 7.1.1 driver.

drumcircle
Rising Star

There is an undocumented flag which resolves windows ODBC connection issues from tools like Excel and Alteryx in version 7.1

In the ODBC data source administration, supply the additional, advanced parameter LegacyEncryption=Y.
 
1. Go to ODBC Data Source Administrator (64-bit).
2. Select the DSN and click Configure.
3. Go to Advanced tab.
4. In the field of Additional connection string parameters, add the below line
 
LegacyEncryption=Y
 
5. Now, go to Connection tab and click Test Connection. If the connection is successful, then click Ok else check the configuration once again.
6. Now, try to establish the connection using the configured DSN in Microsoft Excel. If still the error is persisting, then please send the ODBC log file generated by the Microsoft Excel for the newly configured DSN.

Thank you support for finding a solution.  I suspect there will be a new approach in the future.

View solution in original post

exa-ThomasB
Team Exasol
Team Exasol

This behavior will be fixed in release 7.1.2 and this workaround will not be needed anymore. 

exa-MathiasHo
Community Manager
Community Manager

That's great to hear. Thank you for your input here @exa-ThomasB!